1
0
mirror of https://github.com/cybuzuma/aur_opencpn.git synced 2025-05-28 08:40:11 -07:00

Incorporated wxWidgets patch to fix failing builds

This commit is contained in:
Alexander Volkov 2019-05-14 22:25:08 +01:00
parent e01d485c48
commit efbefd4b3a
4 changed files with 91 additions and 22 deletions

View File

@ -1,7 +1,7 @@
pkgbase = opencpn
pkgdesc = Open Source Chart Plotting / Marine Navigation
pkgver = 5.0.0
pkgrel = 1
pkgrel = 2
url = http://opencpn.org
install = opencpn.install
arch = x86_64
@ -13,7 +13,9 @@ pkgbase = opencpn
depends = tinyxml
depends = hicolor-icon-theme
source = https://github.com/OpenCPN/OpenCPN/archive/v5.0.0.tar.gz
source = wxWidgets.patch
sha1sums = 9ef9ef76ccd94f2a970ef0689a487aec33b19125
sha1sums = e40584dae18b4f4522e5e24491fb5cb212913467
pkgname = opencpn

View File

@ -10,7 +10,7 @@
pkgname=opencpn
pkgver=5.0.0
pkgrel=1
pkgrel=2
pkgdesc="Open Source Chart Plotting / Marine Navigation"
arch=('x86_64')
license=("GPL2")
@ -18,8 +18,14 @@ depends=('wxgtk3' 'gpsd' 'portaudio' 'tinyxml' 'hicolor-icon-theme')
makedepends=('cmake')
url="http://opencpn.org"
install=opencpn.install
source=("https://github.com/OpenCPN/OpenCPN/archive/v5.0.0.tar.gz")
sha1sums=('9ef9ef76ccd94f2a970ef0689a487aec33b19125')
source=("https://github.com/OpenCPN/OpenCPN/archive/v5.0.0.tar.gz" "wxWidgets.patch")
sha1sums=('9ef9ef76ccd94f2a970ef0689a487aec33b19125'
'e40584dae18b4f4522e5e24491fb5cb212913467')
prepare() {
cd "OpenCPN-${pkgver}"
patch --forward --strip=1 --input="${srcdir}/wxWidgets.patch"
}
build() {
cd "OpenCPN-${pkgver}"

View File

@ -1,18 +0,0 @@
diff --git a/include/triangulate.h b/include/triangulate.h
index 7a12790..74239b2 100644
--- a/include/triangulate.h
+++ b/include/triangulate.h
@@ -245,4 +245,13 @@ extern int read_segments(char *, int *);
extern int math_logstar_n(int);
extern int math_N(int, int);
+extern inline int int_greater_than(ipoint_t *v0, ipoint_t *v1);
+extern inline int int_equal_to(ipoint_t *v0, ipoint_t *v1);
+extern inline int int_greater_than_equal_to(ipoint_t *v0, ipoint_t *v1);
+extern inline int int_less_than(ipoint_t *v0, ipoint_t *v1);
+#ifndef __clang__
+extern inline int int_locate_endpoint_a(ipoint_t *v, ipoint_t *vo, int r);
+#endif
+extern inline int int_locate_endpoint(ipoint_t *v, ipoint_t *vo, int r);
+
#endif /* triangulate_h */

79
wxWidgets.patch Normal file
View File

@ -0,0 +1,79 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fcec1191a..8df2a9e21 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -408,9 +408,9 @@ IF((_wx_selected_config MATCHES "qt-armv7"))
ENDIF()
IF((_wx_selected_config MATCHES "qt-armv7"))
- SET(wxWidgets_USE_LIBS base core xml html adv aui)
+ SET(wxWidgets_FIND_COMPONENTS base core xml html adv aui)
ELSE()
- SET(wxWidgets_USE_LIBS net xml html adv aui core base webview)
+ SET(wxWidgets_FIND_COMPONENTS net xml html adv aui core base webview)
ENDIF()
OPTION (USE_GL "Enable OpenGL support" ON)
@@ -436,7 +436,7 @@ IF (ARCH MATCHES "arm*" AND (NOT QT_ANDROID) AND CMAKE_SYSTEM_NAME MATCHES ".*Li
SET(OPENGLES_FOUND "YES")
SET(OPENGL_FOUND "YES")
- SET(wxWidgets_USE_LIBS ${wxWidgets_USE_LIBS} gl )
+ SET(wxWidgets_FIND_COMPONENTS ${wxWidgets_FIND_COMPONENTS} gl )
add_subdirectory(src/glshim)
SET(OPENGL_LIBRARIES "GL_static" "EGL" "X11" "drm" )
@@ -455,7 +455,7 @@ IF(QT_ANDROID)
SET(OPENGLES_FOUND "YES")
SET(OPENGL_FOUND "YES")
- SET(wxWidgets_USE_LIBS ${wxWidgets_USE_LIBS} gl )
+ SET(wxWidgets_FIND_COMPONENTS ${wxWidgets_FIND_COMPONENTS} gl )
add_subdirectory(src/glshim)
ENDIF(QT_ANDROID)
@@ -468,7 +468,7 @@ IF ((NOT OPENGLES_FOUND) AND (NOT QT_ANDROID))
ENDIF(USE_GL)
IF(OPENGL_FOUND)
- SET(wxWidgets_USE_LIBS gl ${wxWidgets_USE_LIBS} )
+ SET(wxWidgets_FIND_COMPONENTS gl ${wxWidgets_FIND_COMPONENTS} )
INCLUDE_DIRECTORIES(${OPENGL_INCLUDE_DIR})
MESSAGE (STATUS "Found OpenGL...." )
@@ -529,14 +529,14 @@ IF(NOT QT_ANDROID)
ENDIF(MSVC)
IF(WIN32 OR APPLE OR QT_ANDROID)
- FIND_PACKAGE(wxWidgets)
+ FIND_PACKAGE(wxWidgets COMPONENTS ${wxWidgets_FIND_COMPONENTS})
if (wxWidgets_FOUND)
message(STATUS "Found wxWidgets webview add-on")
add_definitions(-DOCPN_USE_WEBVIEW)
else ()
- list(REMOVE_ITEM wxWidgets_USE_LIBS webview)
+ list(REMOVE_ITEM wxWidgets_FIND_COMPONENTS webview)
message(STATUS "Could not find wxWidgets webview add-on")
- FIND_PACKAGE(wxWidgets REQUIRED)
+ FIND_PACKAGE(wxWidgets REQUIRED COMPONENTS ${wxWidgets_FIND_COMPONENTS})
endif ()
IF(MSYS)
# this is to convert msys to windows paths, and handle the missing /usr
@@ -1053,14 +1053,14 @@ IF(NOT WIN32 AND NOT APPLE AND NOT QT_ANDROID)
set(wxWidgets_CONFIG_OPTIONS ${wxWidgets_CONFIG_OPTIONS} --toolkit=gtk3)
MESSAGE(STATUS "Building against GTK3...")
ENDIF(GTK2_FOUND)
- FIND_PACKAGE(wxWidgets)
+ FIND_PACKAGE(wxWidgets COMPONENTS ${wxWidgets_FIND_COMPONENTS})
if (wxWidgets_FOUND)
message(STATUS "Found wxWidgets webview add-on")
add_definitions(-DOCPN_USE_WEBVIEW)
else ()
- list(REMOVE_ITEM wxWidgets_USE_LIBS webview)
+ list(REMOVE_ITEM wxWidgets_FIND_COMPONENTS webview)
message(STATUS "Could not find wxWidgets webview add-on")
- FIND_PACKAGE(wxWidgets REQUIRED)
+ FIND_PACKAGE(wxWidgets REQUIRED COMPONENTS ${wxWidgets_FIND_COMPONENTS})
endif ()
MESSAGE (STATUS "Found wxWidgets..." )
MESSAGE (STATUS " wxWidgets Include: ${wxWidgets_INCLUDE_DIRS}")u