mirror of
https://github.com/cybuzuma/aur_opencpn.git
synced 2025-05-28 09:40:17 -07:00
No history for you since aur is stupid
This commit is contained in:
commit
ec01d70048
22
.SRCINFO
Normal file
22
.SRCINFO
Normal file
@ -0,0 +1,22 @@
|
||||
pkgbase = opencpn
|
||||
pkgdesc = Open Source Chart Plotting / Marine Navigation
|
||||
pkgver = 4.0.0
|
||||
pkgrel = 2
|
||||
url = http://opencpn.org
|
||||
install = opencpn.install
|
||||
arch = i686
|
||||
arch = x86_64
|
||||
license = GPL2
|
||||
makedepends = cmake
|
||||
depends = wxgtk2.8
|
||||
depends = gpsd
|
||||
depends = portaudio
|
||||
depends = tinyxml
|
||||
depends = hicolor-icon-theme
|
||||
source = https://github.com/OpenCPN/OpenCPN/archive/v4.0.0.tar.gz
|
||||
source = gcc5.patch
|
||||
sha1sums = c128d1d17bdc3bc9c19d3ae2f2ee8ea1a3b5bc20
|
||||
sha1sums = e1b8bb165328104b927dd4c5b0d8704514008af5
|
||||
|
||||
pkgname = opencpn
|
||||
|
42
PKGBUILD
Normal file
42
PKGBUILD
Normal file
@ -0,0 +1,42 @@
|
||||
# ---------------------------------------------------------------
|
||||
# Maintainer: Øyvind 'Mr.Elendig' Heggstad <mrelendig at har-ikkje dot net>
|
||||
# Original contributor: Travis Fickett <tfickett AT ufl DOT edu>
|
||||
# Original Maintainer: Anders Lund <anders at alweb dot dk>
|
||||
# ---------------------------------------------------------------
|
||||
# Adopted temporarily by Bruno Rodriguez (brunorro) on 2013-06-20
|
||||
# - Just changed the pkgver, the source and the md5sums to make
|
||||
# it work. If you can make it better, adopt it !
|
||||
# ---------------------------------------------------------------
|
||||
|
||||
pkgname=opencpn
|
||||
pkgver=4.0.0
|
||||
pkgrel=2
|
||||
pkgdesc="Open Source Chart Plotting / Marine Navigation"
|
||||
arch=('i686' 'x86_64')
|
||||
license=("GPL2")
|
||||
depends=('wxgtk2.8' 'gpsd' 'portaudio' 'tinyxml' 'hicolor-icon-theme')
|
||||
makedepends=('cmake')
|
||||
url="http://opencpn.org"
|
||||
install=opencpn.install
|
||||
source=("https://github.com/OpenCPN/OpenCPN/archive/v4.0.0.tar.gz"
|
||||
"gcc5.patch")
|
||||
sha1sums=('c128d1d17bdc3bc9c19d3ae2f2ee8ea1a3b5bc20'
|
||||
'e1b8bb165328104b927dd4c5b0d8704514008af5')
|
||||
|
||||
prepare() {
|
||||
cd "OpenCPN-${pkgver}"
|
||||
patch -Np1 -i ../gcc5.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "OpenCPN-${pkgver}"
|
||||
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr\
|
||||
-DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-2.8\
|
||||
-DwxWidgets_wxrc_EXECUTABLE=/usr/bin/wxrc-2.8
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "OpenCPN-${pkgver}"
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
18
gcc5.patch
Normal file
18
gcc5.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff --git a/include/triangulate.h b/include/triangulate.h
|
||||
index 7a12790..74239b2 100644
|
||||
--- a/include/triangulate.h
|
||||
+++ b/include/triangulate.h
|
||||
@@ -245,4 +245,13 @@ extern int read_segments(char *, int *);
|
||||
extern int math_logstar_n(int);
|
||||
extern int math_N(int, int);
|
||||
|
||||
+extern inline int int_greater_than(ipoint_t *v0, ipoint_t *v1);
|
||||
+extern inline int int_equal_to(ipoint_t *v0, ipoint_t *v1);
|
||||
+extern inline int int_greater_than_equal_to(ipoint_t *v0, ipoint_t *v1);
|
||||
+extern inline int int_less_than(ipoint_t *v0, ipoint_t *v1);
|
||||
+#ifndef __clang__
|
||||
+extern inline int int_locate_endpoint_a(ipoint_t *v, ipoint_t *vo, int r);
|
||||
+#endif
|
||||
+extern inline int int_locate_endpoint(ipoint_t *v, ipoint_t *vo, int r);
|
||||
+
|
||||
#endif /* triangulate_h */
|
15
opencpn.install
Normal file
15
opencpn.install
Normal file
@ -0,0 +1,15 @@
|
||||
post_install() {
|
||||
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
Loading…
x
Reference in New Issue
Block a user