mirror of
https://github.com/cybuzuma/aur_opencpn.git
synced 2025-05-21 16:10:18 -07:00
Updated to v5.2
This commit is contained in:
parent
cd37a71030
commit
4b10dba786
10
.SRCINFO
10
.SRCINFO
@ -1,7 +1,7 @@
|
|||||||
pkgbase = opencpn
|
pkgbase = opencpn
|
||||||
pkgdesc = Open Source Chart Plotting / Marine Navigation
|
pkgdesc = Open Source Chart Plotting / Marine Navigation
|
||||||
pkgver = 5.0.0
|
pkgver = 5.2.0
|
||||||
pkgrel = 3
|
pkgrel = 1
|
||||||
url = http://opencpn.org
|
url = http://opencpn.org
|
||||||
install = opencpn.install
|
install = opencpn.install
|
||||||
arch = x86_64
|
arch = x86_64
|
||||||
@ -13,10 +13,8 @@ pkgbase = opencpn
|
|||||||
depends = tinyxml
|
depends = tinyxml
|
||||||
depends = hicolor-icon-theme
|
depends = hicolor-icon-theme
|
||||||
depends = webkit2gtk
|
depends = webkit2gtk
|
||||||
source = https://github.com/OpenCPN/OpenCPN/archive/v5.0.0.tar.gz
|
source = https://github.com/OpenCPN/OpenCPN/archive/v5.2.0.tar.gz
|
||||||
source = wxWidgets.patch
|
sha1sums = 352037909fde8a7195f740ed6a0f8d1eff8e9e78
|
||||||
sha1sums = 9ef9ef76ccd94f2a970ef0689a487aec33b19125
|
|
||||||
sha1sums = e40584dae18b4f4522e5e24491fb5cb212913467
|
|
||||||
|
|
||||||
pkgname = opencpn
|
pkgname = opencpn
|
||||||
|
|
||||||
|
29
PKGBUILD
29
PKGBUILD
@ -1,16 +1,13 @@
|
|||||||
# ---------------------------------------------------------------
|
# Maintainer: trougnouf (Benoit Brummer) <trougnouf at gmail dot com>
|
||||||
# Maintainer: Øyvind 'Mr.Elendig' Heggstad <mrelendig at har-ikkje dot net>
|
# Contributor: Bruno Rodriguez (brunorro)
|
||||||
# Original contributor: Travis Fickett <tfickett AT ufl DOT edu>
|
# Contributor: Øyvind 'Mr.Elendig' Heggstad <mrelendig at har-ikkje dot net>
|
||||||
# Original Maintainer: Anders Lund <anders at alweb dot dk>
|
# Contributor: Travis Fickett <tfickett AT ufl DOT edu>
|
||||||
# ---------------------------------------------------------------
|
# Submitter: Anders Lund <anders at alweb dot dk>
|
||||||
# Adopted temporarily by Bruno Rodriguez (brunorro) on 2013-06-20
|
|
||||||
# - Just changed the pkgver, the source and the md5sums to make
|
|
||||||
# it work. If you can make it better, adopt it !
|
|
||||||
# ---------------------------------------------------------------
|
|
||||||
|
|
||||||
pkgname=opencpn
|
pkgname=opencpn
|
||||||
pkgver=5.0.0
|
_name="OpenCPN"
|
||||||
pkgrel=3
|
pkgver=5.2.0
|
||||||
|
pkgrel=1
|
||||||
pkgdesc="Open Source Chart Plotting / Marine Navigation"
|
pkgdesc="Open Source Chart Plotting / Marine Navigation"
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
license=("GPL2")
|
license=("GPL2")
|
||||||
@ -18,14 +15,8 @@ depends=('wxgtk3' 'gpsd' 'portaudio' 'tinyxml' 'hicolor-icon-theme' 'webkit2gtk'
|
|||||||
makedepends=('cmake')
|
makedepends=('cmake')
|
||||||
url="http://opencpn.org"
|
url="http://opencpn.org"
|
||||||
install=opencpn.install
|
install=opencpn.install
|
||||||
source=("https://github.com/OpenCPN/OpenCPN/archive/v5.0.0.tar.gz" "wxWidgets.patch")
|
source=("https://github.com/${_name}/${_name}/archive/v${pkgver}.tar.gz") # "wxWidgets.patch")
|
||||||
sha1sums=('9ef9ef76ccd94f2a970ef0689a487aec33b19125'
|
sha1sums=('352037909fde8a7195f740ed6a0f8d1eff8e9e78')
|
||||||
'e40584dae18b4f4522e5e24491fb5cb212913467')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "OpenCPN-${pkgver}"
|
|
||||||
patch --forward --strip=1 --input="${srcdir}/wxWidgets.patch"
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "OpenCPN-${pkgver}"
|
cd "OpenCPN-${pkgver}"
|
||||||
|
@ -1,79 +0,0 @@
|
|||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index fcec1191a..8df2a9e21 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -408,9 +408,9 @@ IF((_wx_selected_config MATCHES "qt-armv7"))
|
|
||||||
ENDIF()
|
|
||||||
|
|
||||||
IF((_wx_selected_config MATCHES "qt-armv7"))
|
|
||||||
- SET(wxWidgets_USE_LIBS base core xml html adv aui)
|
|
||||||
+ SET(wxWidgets_FIND_COMPONENTS base core xml html adv aui)
|
|
||||||
ELSE()
|
|
||||||
- SET(wxWidgets_USE_LIBS net xml html adv aui core base webview)
|
|
||||||
+ SET(wxWidgets_FIND_COMPONENTS net xml html adv aui core base webview)
|
|
||||||
ENDIF()
|
|
||||||
|
|
||||||
OPTION (USE_GL "Enable OpenGL support" ON)
|
|
||||||
@@ -436,7 +436,7 @@ IF (ARCH MATCHES "arm*" AND (NOT QT_ANDROID) AND CMAKE_SYSTEM_NAME MATCHES ".*Li
|
|
||||||
SET(OPENGLES_FOUND "YES")
|
|
||||||
SET(OPENGL_FOUND "YES")
|
|
||||||
|
|
||||||
- SET(wxWidgets_USE_LIBS ${wxWidgets_USE_LIBS} gl )
|
|
||||||
+ SET(wxWidgets_FIND_COMPONENTS ${wxWidgets_FIND_COMPONENTS} gl )
|
|
||||||
add_subdirectory(src/glshim)
|
|
||||||
|
|
||||||
SET(OPENGL_LIBRARIES "GL_static" "EGL" "X11" "drm" )
|
|
||||||
@@ -455,7 +455,7 @@ IF(QT_ANDROID)
|
|
||||||
SET(OPENGLES_FOUND "YES")
|
|
||||||
SET(OPENGL_FOUND "YES")
|
|
||||||
|
|
||||||
- SET(wxWidgets_USE_LIBS ${wxWidgets_USE_LIBS} gl )
|
|
||||||
+ SET(wxWidgets_FIND_COMPONENTS ${wxWidgets_FIND_COMPONENTS} gl )
|
|
||||||
add_subdirectory(src/glshim)
|
|
||||||
ENDIF(QT_ANDROID)
|
|
||||||
|
|
||||||
@@ -468,7 +468,7 @@ IF ((NOT OPENGLES_FOUND) AND (NOT QT_ANDROID))
|
|
||||||
ENDIF(USE_GL)
|
|
||||||
|
|
||||||
IF(OPENGL_FOUND)
|
|
||||||
- SET(wxWidgets_USE_LIBS gl ${wxWidgets_USE_LIBS} )
|
|
||||||
+ SET(wxWidgets_FIND_COMPONENTS gl ${wxWidgets_FIND_COMPONENTS} )
|
|
||||||
INCLUDE_DIRECTORIES(${OPENGL_INCLUDE_DIR})
|
|
||||||
|
|
||||||
MESSAGE (STATUS "Found OpenGL...." )
|
|
||||||
@@ -529,14 +529,14 @@ IF(NOT QT_ANDROID)
|
|
||||||
ENDIF(MSVC)
|
|
||||||
|
|
||||||
IF(WIN32 OR APPLE OR QT_ANDROID)
|
|
||||||
- FIND_PACKAGE(wxWidgets)
|
|
||||||
+ FIND_PACKAGE(wxWidgets COMPONENTS ${wxWidgets_FIND_COMPONENTS})
|
|
||||||
if (wxWidgets_FOUND)
|
|
||||||
message(STATUS "Found wxWidgets webview add-on")
|
|
||||||
add_definitions(-DOCPN_USE_WEBVIEW)
|
|
||||||
else ()
|
|
||||||
- list(REMOVE_ITEM wxWidgets_USE_LIBS webview)
|
|
||||||
+ list(REMOVE_ITEM wxWidgets_FIND_COMPONENTS webview)
|
|
||||||
message(STATUS "Could not find wxWidgets webview add-on")
|
|
||||||
- FIND_PACKAGE(wxWidgets REQUIRED)
|
|
||||||
+ FIND_PACKAGE(wxWidgets REQUIRED COMPONENTS ${wxWidgets_FIND_COMPONENTS})
|
|
||||||
endif ()
|
|
||||||
IF(MSYS)
|
|
||||||
# this is to convert msys to windows paths, and handle the missing /usr
|
|
||||||
@@ -1053,14 +1053,14 @@ IF(NOT WIN32 AND NOT APPLE AND NOT QT_ANDROID)
|
|
||||||
set(wxWidgets_CONFIG_OPTIONS ${wxWidgets_CONFIG_OPTIONS} --toolkit=gtk3)
|
|
||||||
MESSAGE(STATUS "Building against GTK3...")
|
|
||||||
ENDIF(GTK2_FOUND)
|
|
||||||
- FIND_PACKAGE(wxWidgets)
|
|
||||||
+ FIND_PACKAGE(wxWidgets COMPONENTS ${wxWidgets_FIND_COMPONENTS})
|
|
||||||
if (wxWidgets_FOUND)
|
|
||||||
message(STATUS "Found wxWidgets webview add-on")
|
|
||||||
add_definitions(-DOCPN_USE_WEBVIEW)
|
|
||||||
else ()
|
|
||||||
- list(REMOVE_ITEM wxWidgets_USE_LIBS webview)
|
|
||||||
+ list(REMOVE_ITEM wxWidgets_FIND_COMPONENTS webview)
|
|
||||||
message(STATUS "Could not find wxWidgets webview add-on")
|
|
||||||
- FIND_PACKAGE(wxWidgets REQUIRED)
|
|
||||||
+ FIND_PACKAGE(wxWidgets REQUIRED COMPONENTS ${wxWidgets_FIND_COMPONENTS})
|
|
||||||
endif ()
|
|
||||||
MESSAGE (STATUS "Found wxWidgets..." )
|
|
||||||
MESSAGE (STATUS " wxWidgets Include: ${wxWidgets_INCLUDE_DIRS}")u
|
|
Loading…
x
Reference in New Issue
Block a user